Team Integra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My driver side wiper blade is skipping half the window, to the point where it doesn't even touch half the window, when going over 60mph. Tried new blades and tightening the arm bolt. Is the arm bent or to much air causing it to raise up? Or something else? Thanks
Mickey
 

·
Registered
Joined
·
11,935 Posts
If you just replaced the blade...you may have to replace the blade holder...not the arm.
 

·
Registered
Joined
·
16,250 Posts
Brand of the blades plays a big role. How does the wiper arm look/feel? Is the spring still tight? Make sure the wiper arms are secured tightly. I will get you the article from out articles section on wiper blades.

All about wiper blades
 

·
Registered
Joined
·
269 Posts
my driver wiper arm did the same thing, only it was because the arm bent because it was iced to my window and i accidently turned my wipers on when i was trying to turn the rear one on. tries bending it back but there no way to get it perfect the way it was, had to replace it. may not be your problem tho. try changing the blade and holder together instead of just using refills.
 

·
Registered
Joined
·
10,393 Posts
Get one of those aftermarket addon spring, and you will be fine. I just installed mine 2 weeks ago, i can go up to 80mpr no problem now. But winter only blades does put a lot more drag... i had no problem with my summer blade before until now with the winter blade (it block the wind! thus making it lift up!)
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
Problem solved. Went to the Honda dealership here in Holland and got a new blade with what they call a spoiler on it. No problmes at any speed. Thanks for the replies.
Mickey
 
1 - 7 of 7 Posts
Top