Team Integra Forums banner
1341 - 1360 of 1378 Posts

· Registered
ITR trans, 84mm sleeved, studded. Tokico/tein, FR trac bar
Joined
·
111 Posts
Tested new oil pressure sensor line... need more parts. Tried factory intake manifold bracket from a friend... need to order one. Can’t wait to get this Procharger setup started!
 

· Registered
Joined
·
22 Posts
Got a new battery, and trying to fix my subwoofer. Not sure if the amp is overheating (it has been around 100°F for the past few days around when the issue started), or my battery isn’t supplying enough voltage, or my grounds are corroded (doubt it they look fine). Idk but my mids aren’t that great for bass at all. But yea the amp keeps going into safe mode. I have been needing to get a new battery for a while now so it works out.
 

· Registered
Joined
·
766 Posts
mine is on jack stands currently since i moved. hoping to get to work on it soon
 

· Premium Member
Joined
·
9,551 Posts
Discussion Starter · #1,354 ·
Miss doing that. Once my two kids don't need car seats I'll be able to do it again.
 

· Registered
Joined
·
1 Posts
Well I have never been on any forum before, today I had the front Springs, shocks and struts replaced tomorrow the rears go on then in the next couple of weeks the new Rack and Pinion goes in. Funny thing I love this little car. I call her "Pickle" shes a work in progress but doing better all the time.
 

· Registered
Joined
·
766 Posts
still no work on it just under covers.
 
1341 - 1360 of 1378 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top