Team Integra Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi don't be too harsh on me I'm new to this forum. Before the swap my motor was seemingly running lean or rich, had a rough idle, bad gas milage, and would sometimes hesitate to accelerate but other than that pulled fine for an ls. Alright, so I then went lsvtec on my ls integra with lsvtec kit at my local shop (pfi South) . It was a ported gsr head stock and the block is stock. Also had a Blox intake installed and was street tuned on hondata. The day I got it back it didn't seem like much more horse power at all other than past like 6k rpm but the torque was noticeably way worse and the idle was still was bad and my gas milage and seemed to pull inconsistently. It wouldn't hesitate to accelerate though. Compression is 160 to 170 across the board. Should I get it diagnosed at a shop? Seems over my head. 😔
 

Attachments

·
Registered
Joined
·
3,818 Posts
it was a ported gsr head stock and the block is stock. Also had a Blox intake installed and was street tuned on hondata. The day I got it back it didn't seem like much more horse power at all other than past like 6k rpm but the torque was noticeably way worse and the idle was still was bad and my gas milage and seemed to pull inconsistently. It wouldn't hesitate to accelerate though. Compression is 160 to 170 across the board.

That is all been done to the motor? If not list everything like ECU, bolts, head studs, camshaft, cam gears, fuel upgrades, etc. so us can help you. 160 is to low.
 
1 - 2 of 2 Posts
About this Discussion
1 Reply
2 Participants
phatintegra
Team Integra Forums
The Team Integra community is a forum dedicated to Acura Integra enthusiasts to discuss engine building, suspension, repair, detailing and anything else Integra related.
Full Forum Listing
Top