Team Integra Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,255 Posts
Discussion Starter #1
w00t w00t... just bought a used USDM ITR cluster... pretty clean with bout 16k miles on the odo... for $120!!!! i hope it was a good buy.

Anywase my question was.. does any1 else have problem with the electrical lights being on? or off? dont know the year of the ITR it came off from, but it went into my 94 RS and the door light wont go off unless i buckle up, and the seat belt light dont even come on at all. Any has this bug too?
 

·
Registered
Joined
·
529 Posts
i was wondering the same thing, also, im not flaming, but is there a reason to use an itr cluster, i mean, you cant rev to 8500 or is it just fo sho
 

·
Registered
Joined
·
1,321 Posts
hold on. there is seat belt light? where the hell is dat at? or is dat in the obd2 vehicles? i gota obd1 95.. LS/SE cluster.. belt light.. see nwo thats freaking me out lol
 

·
Registered
Joined
·
1,255 Posts
Discussion Starter #6
LMFAO seat belt lights are on all cluster..
and how is this off topic? im specifically asking a question bout a problem for G3 tegs...
the reason i bought it was coz mine wasnt working right.. and i was gonna spend the money on just getting a GSR cluster.. but then found an ITR one for bout the same price.. so i got it.. and eventually.. i will be able to rev higher than just 8.4k RPM
 

·
Registered
Joined
·
478 Posts
I found this post in an old thread

TeggyLS on Dec/19/03 said:
i had a early ls cluster maybe 94, 95 or something in my 2000 for a day and:

the srs and seatbelt icons were switched, the abs stayed lit, the maint. re'q light turned on after the ign. was off and stayed on, the fuel and temp shot to the right when i turned it on and remained there till i turned the car off, and when i engaged the blinkers the rpm and mph needles flucuated down-down-up-down-up until i turned them off

something to think about
*EDIT*

Here is the thread I got that from. Sounds like the same situation you have. The last post has the fix for you.
 

·
Registered
Joined
·
49 Posts
i just bought an ITR cluster today in place of my LS cluster. I switched everything that needed to be switched : green film, and the ABS, Seatbelt films, etc... everything works fine, only thing wrong is the door light never turns off and my spedometer is not working correctly. i have a jdm gsr tranny, and at 4000rpm it should be at 80 mph, but instead its only at 58mph or so, does anybody know what the problem is? any help is appreciated, thanks.
 
1 - 10 of 10 Posts
Top