Team Integra Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello, this is my first post on TI. I am having really strange issues with my 1998 GSR... Its been running hot since I got it. Ive replace thermostat, alternator and battery. It doesn't leak coolant, it leaks a small amount of oil. If i keep the RPM's higher than about 3500, it won't overheat, but when cruising it does. Using anything electrical makes the gauge bounce about 1/8, such as turning headlights on and off, turning the heater on. I brought it to a shop and they couldn't find what it was but said its most likely a cracked block but I have my doubts about that. I feel no power loss and see no smoke, and its been doing this for almost 8 months and I daily it about 10 minutes to work every day. Any ideas?
 

·
Registered
Joined
·
167 Posts
A few questions came to mind based on what you're describing. Can you physically see both the fans moving when the engine is running and can you freely move them with your hand when the car is off? Have you checked what your oil looks like recently, that would likely be the best way to identify if you have a cracked block at this point without tearing everything apart. I suspect that when you replaced the thermostat you had to add coolant/flush the coolant, what did it look like before hand (color, etc.)?

The fact that you've been driving it with this issue for 8 months suggests that if any thing seem out of the ordinary with the above you may have already damaged the engine.
 
1 - 2 of 2 Posts
About this Discussion
1 Reply
2 Participants
Absolute_Yeti
Team Integra Forums
The Team Integra community is a forum dedicated to Acura Integra enthusiasts to discuss engine building, suspension, repair, detailing and anything else Integra related.
Full Forum Listing
Top