Team Integra Forums banner
1 - 20 of 34 Posts

·
Registered
Joined
·
281 Posts
Discussion Starter · #1 ·
Alright well, today I took my car to get my new struts and springs put on. KYB GR-2s and Tein S Techs...The DC needed it due to the horrible bouncing ride it had from some horribly cheap coilovers, but it was dropped a good 2.5 -3 inches on them...haha. Well, I leave and come back to find my car looking like an old hot rod with like hoosiers on the back. I mean the front is now lower even a good inch lower than with the coilovers on it (Now 3-4 inches) and the rear raised up about 2-3 inches...Well I thought they may have accidentally mixed up the front and rear and so did they...well they switched them...It looked the exact same....Here are some pics, any ideas on what they could have done? Please...my car looks ridiculous...

Before



Now...what the rear looks like...



The Front Now...



Front bumper from ground...



one more of the rear...

 

·
Registered
Joined
·
150 Posts
Also another thing that could have went wrong is there is a stop washer that the shock is suppose to stop at maybe they didn't put that back on. Its like a washer at the very top and then the shock turns to thicker metal and it just rests at the top causing the strut to stop when it reaches it.
 

·
Registered
Joined
·
281 Posts
Discussion Starter · #8 ·
I would be willing they didn't cut the bump stop...I'm not sure if that has anything to do with it but I dunno...Something is way outta wack
 

·
Registered
Joined
·
281 Posts
Discussion Starter · #9 ·
Another thing that seems odd is that the Tein S Techs that I got were almost the exact same height...Well the coilovers they took off were about an inch different front and back...
 

·
Registered
Joined
·
10,393 Posts
1) either they were stupid enough to put the bumpstop ABOVE the bumpstop washer...
2) they swap it again, but they somehow still messed up in the middle of swapping, probably took the springs out and then end up putting it the exact wrong way back in...

when they do the swap, were u there? you should look at what they do make sure they put everyhting correctly... Tein S is no where near that low at the front. i think the drop is 1.8? which leaves about 1 figer gap front and back...
 

·
Registered
Joined
·
281 Posts
Discussion Starter · #14 ·
See I've heard anything from a 3.6" drop in the front to a 1.5" drop in the front....The site I purchased them from Swerve Motorsports has 2.5 in the front and 1.7 on the rear...I'm going to see what I can find out today...damn this snow though...
 

·
Registered
Joined
·
220 Posts
Shoot man. I've had those springs on both of my cars and neither of them have looked like that at all, front or rear. I'm on kyb agx's though and I put them on myself...Pretty sure I did it correctly, too. haha. Not sure what the problem is. Hope you get it worked out.



 

·
Registered
Joined
·
281 Posts
Discussion Starter · #16 ·
Yeah...it looks nothing like Scott's car...and we have the exact same setup...I just wanna take it somewhere that know's what they are doing...
 

·
Registered
Joined
·
220 Posts
Where did you take them to get them put on? Are they going to reimburse you for doing it incorrectly? If not it's ashame that you'd have to pay to get it done again, as result of someone else's mistake. Good luck.
 

·
Registered
Joined
·
281 Posts
Discussion Starter · #19 ·
Well, I just went and took a look at the #s on the springs...the ones on the front 010650s and the ones on the rear are 010950s...I'm thinking this is for the spring it's self b/c it's nothing like the part # for the whole set whick is SKA18 AUB00...I can't find the number I found anywhere....

Also...When I got my springs all 4 of mine looked similar to the outside 2 in this pic I found of them...

 
1 - 20 of 34 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top