Team Integra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
So I have always had a surging idle on my car ever since I got it. It's a B18B1 on a 1994 Acura Integra RS. The surging only happens when the engine is cold but slowly goes away once the engine warms up. I am not sure if this could just be a simple IACV fix or what? ALSO I have had a hose that never been connecting to anything and i am not sure what it was supposed to ever be connected to(I have it circled in yellow in the picture). I know the engine bay is pretty disgusting. Cant really help it. It came from up north :(

image1 (1).jpeg
image1 (1).jpeg
 

·
Registered
Joined
·
9 Posts
I would clean the iacv and the fitv valve, also check for a tear in the throttle body gasket. As for the hose on the throttle body I believe thats for you egr purge, but I have a hose like that on mine with no problems.
 

·
Registered
Joined
·
11 Posts
Yeah that hose goes to the evap canister under the intake manifold mine broke off too have you tried bleeding the air from the coolant sometimes it can be a pain and take forever but it's easy if you have the funnel that connects to your radiator fill cap
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
Yeah that hose goes to the evap canister under the intake manifold mine broke off too have you tried bleeding the air from the coolant sometimes it can be a pain and take forever but it's easy if you have the funnel that connects to your radiator fill cap
Yeah ive tried every little thing you can possible do to try and make the surge go away, but i think its just bad iacv valve
 

·
Registered
Joined
·
11 Posts
Yeah ive tried every little thing you can possible do to try and make the surge go away, but i think its just bad iacv valve
Yeah I bought one for 75 from discount body parts and they sent it to me with a small crack by the seal and when I installed it it acted like it was unplugged and idled at 450rpms but that's what you get for going cheap i returned it and just gonna spend the 200 on a new one unless anyone can tell me where i can order a reliable iacv for cheap also I was thinking about getting a bloxracing TB without the fitv 66mm and replacing both the tps and map sensor any thoughts on that have you tried swapping all those out?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #8
Yeah I bought one for 75 from discount body parts and they sent it to me with a small crack by the seal and when I installed it it acted like it was unplugged and idled at 450rpms but that's what you get for going cheap i returned it and just gonna spend the 200 on a new one unless anyone can tell me where i can order a reliable iacv for cheap also I was thinking about getting a bloxracing TB without the fitv 66mm and replacing both the tps and map sensor any thoughts on that have you tried swapping all those out?
I have no tried replacing the tps or map sensor yet no. Its all pretty much from factory. You can try ROCKAUTO.COM. They usually have the cheapest oem style parts that are reliable.
 
1 - 8 of 8 Posts
Top