Team Integra Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
448 Posts
Discussion Starter · #1 ·
today my power steering pump started sqeeling pretty loud. it only does it when at idle and its very annoying. im like 90% sure thats where it is coming from, could be the ac compressor but most likely the power steering pump. anyone have this happen to them? what was the problem? can it be rebuilt?
 

·
Banned
Joined
·
9,126 Posts
I have this kind of problem too except, mine sounds more supercharger-ish kind a whining/ringing sound. It does it at idle and when im driving and it annoys the crap out of me. Anyone know how to fix this?
 

·
Registered
Joined
·
904 Posts
97lsteggy on Feb/26/08 said:
I have this kind of problem too except, mine sounds more supercharger-ish kind a whining/ringing sound. It does it at idle and when im driving and it annoys the crap out of me. Anyone know how to fix this?
this is actually a bearing failure. You need to replace it asap before the bearing/pump lock up on you. I have had this same crap happen to me numerous times. its better to replace it before it locks up and ruins your belts and ****
 

·
Registered
Joined
·
904 Posts
ABP98LS on Feb/26/04 said:
today my power steering pump started sqeeling pretty loud. it only does it when at idle and its very annoying. im like 90% sure thats where it is coming from, could be the ac compressor but most likely the power steering pump. anyone have this happen to them? what was the problem? can it be rebuilt?
have you tried tightening the belt? There are two 12mm bolts that attach the pump to the bracket, loosen those and adjust the wing nut on top of the bracket so that it tightens/puts more tension on the belt. then tighten the 12mm bolts back down.

If that doesnt solve your problem then its most likely you a/c belt. In which case you can tighten that one to
 

·
Banned
Joined
·
9,126 Posts
g3integragsr on Feb/26/08 said:
Quote: 97lsteggy on Feb/26/08I have this kind of problem too except, mine sounds more supercharger-ish kind a whining/ringing sound. It does it at idle and when im driving and it annoys the crap out of me. Anyone know how to fix this?

this is actually a bearing failure. You need to replace it asap before the bearing/pump lock up on you. I have had this same crap happen to me numerous times. its better to replace it before it locks up and ruins your belts and ****
How much and what parts do i need to purchase to fix this? Is there anyway like any tests i can do to ensure it is indeed a bearing failure? And if it is a bearing failure is there a write up DIY anywhere or is it a pretty straight foreward job?
 

·
Registered
Joined
·
717 Posts
could also be the alternator belt. they squeel when loose, so make sure everything is tight
 

·
Registered
Joined
·
9,719 Posts
Check fluid level.
Check fluid for air.
Check belt tension.
Then check bearing as mentioned.


By this time, you might as well replace P/S pump because its so much easier.
 

·
Registered
Joined
·
4,563 Posts
If you're in need of a replacement pump, I have one from my 96 Integra. It's in very good condition, no noise, leaks, anything bad etc...
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top