Team Integra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9,908 Posts
Discussion Starter #1
I installed my H&R springs and kyb adjustable shock today.

The most upper part of the shock where the cap goes over the spring and it held by one screw was on pretty tight, I left about the same amount at the stock setup had when tightening it. But when the springs went on the car, and we lowered the car that screw got loose.

Now the washer under it is lose, is that how it's supposed to be, someone told me not to make it tighter because it might blow the shock?

oh and now my itr strut bar in the front doesnt seem to fit. what am I doing wrong?

I also hear weir noises when hit certain bumps. like minor rattling.

any advice help? I think I did eveyrthing as I should have.
 

·
Registered
Joined
·
7,037 Posts
From my understanding washers are supposed to be flush with the screw and the bottom of what its connected to, just tighten it up, and if it works ok, and if not just loosen it. Sorry im no expert in this deal but I know how frustrating it is not to get an answer.
 

·
Registered
Joined
·
634 Posts
bro you did this yourself?? let me know your ride quality because im prolly gettin those KYB adjustable shocks but dunno which springs.. i dont want a dumb low drop.. just a moderate 1.5 like Eibach Pro-Kit... tell me how yer springs are...
 

·
Registered
Joined
·
9,908 Posts
Discussion Starter #6
the drop is awsome sonic, just what I wanted, u can come by chek it out later.

does anyone know the proper torque for the upper part screw of the shock assembly? anyone have a manual they can look it up in?

and btw, good looking out showdow, it is frustrating when you're in the middle of a project and you can't get replies, but u can't blame ppl, not everyone is on TI all the time all day, or maybe.............

thanks
 
1 - 6 of 6 Posts
Top