Team Integra Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
1,147 Posts
Discussion Starter · #1 ·
I recently noticed in my 95 GSR that when I go over small, quick bumps, I hear a small "popping" coming from the rear of the car. Now I assume that it is either the struts, or rear ball joints. How to tell the difference?

However, the struts in the rear are newer (only about 2.5 years old, KYB AGX on about a 1" drop). And, when I go on the auto parts websites (NAPA, Autozone, etc), I don't see there being any rear ball joints listed. Is there a upper and lower ball joint like the front of the car has?

How hard is it to replace the ball joints in the rear?

Any help or suggestions are appreciated. Thanks dudes
 

·
Registered
Joined
·
74 Posts
mine is doin the same thing. i have skunk2 springs and shocks with omni power lcas and only have had them for about 7 months. when ever i go over small humps i get the popping noise 2. ive checked everything as far loose nuts and stuff and making sure everything is tight, but it didnt make any difference. help would b greatly appreciated.
 

·
Registered
Joined
·
339 Posts
A big annoyance and issue with older Integras is the Rear Trailing Arm Bushings. Take a look at those and see if those are bad. They aren't relatively expensive and can be replaced without too much headache.
 

·
Registered
Joined
·
1,147 Posts
Discussion Starter · #5 ·
I'll have to take a look at them next time I give it an oil change. Now that I've really been paying attention, the "popping" sounds like it's coming more from the middle rear section of the car, not right by the struts. Hopefully it is just the bushings. I looked at advancedautoparts, and they sell the set for around $40.

Anyone else have this problem?
 

·
Registered
Joined
·
339 Posts
I used to have this problem, but got them replaced. They weren't exactly "bad" but they were on the way out within the next 6 months. Had them replaced and no noise is heard :).
 

·
Registered
Joined
·
1,147 Posts
Discussion Starter · #7 ·
YungFrshCrckr on Sep/11/07 said:
I used to have this problem, but got them replaced. They weren't exactly "bad" but they were on the way out within the next 6 months. Had them replaced and no noise is heard :).
Are you referring to the rear sway arm bushings?

Thanks
 

·
Registered
Joined
·
1 Posts
homeslice229 on Sep/05/07 said:
I'll have to take a look at them next time I give it an oil change. Now that I've really been paying attention, the "popping" sounds like it's coming more from the middle rear section of the car, not right by the struts. Hopefully it is just the bushings. I looked at advancedautoparts, and they sell the set for around $40.

Anyone else have this problem?
i have this problem too most of tha time when i turn but im on tein basics asr subframe and 98 itr sway. help would be appreciated.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top