Team Integra Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
i have a 2k gsr, which is making noise from the right radiator fan(facing the front of the car) when it is turned on. anyone have any clue?
 

·
Registered
Joined
·
496 Posts
did you check for obstructions? loose cables and such? maybe a twig found it's way in there? maybe a squirrel is living in your radiator fans =)
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
well, first i found a tooth of a deer,then some beef jerky..but yeah i found a squirrel in there running on the fans...thank god its just a squirell..i took it out and cooked it southern styleee...

anyways, when the fan turns on at idle, it sounds loud and abnormal..i checked for any obstructions..but werent any..so i was just checking to see if anyone here had similar problems..
 

·
Registered
Joined
·
412 Posts
just spray some lubricant into the spinning bearing and it'll clear up just fine.
 

·
Registered
Joined
·
1,415 Posts
i also had this problem. turned out it was loose screws. try that. though the noise is still there, but only at a minimum. and im gonna try spraying some lubricant on it pretty soon, see if that helps.
 

·
Registered
Joined
·
1,376 Posts
O i had that noise before sorta like a squirrel screaming right? LOL well the fan is loose so check that. I brought it to a shop than BAM!!!!!!!!
 

·
Registered
Joined
·
3,386 Posts
yeah make sure all your screws are tight had this prob with my civic a lil work with a 10 mil and a screwdriver you can fix anything on a teg. not really but ya know what i mean.
 

·
Registered
Joined
·
27 Posts
I've started to have this problem too. It is the A/C fan and only screeches sometimes. It seems like it happens more often when it is hotter out (85+ degrees). What do I need to lubricate, and which screws do you think could be loose? Thanks in advance!
 
1 - 9 of 9 Posts
Top