Team Integra Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I’m getting a misfire on my 97 RS. It’s stock engine. No work really done to the car yet and recently changed out the spark plugs about 2 months ago. I was accelerating to about 80 on the freeway when my engine light came on. I got the codes checked and came back with P0303. I had the code before but went away by itself. My engine tried to stall itself out below 1000 rpm. Keeping gas on the car keeps it alive, but still runs rough. Swapped spark plugs, check SP wires and they looked good, and swapped to a new distributer and nothing changed. My friend tells me it might be valve seals. Any recommendations?
 

·
Administrator
Joined
·
3,583 Posts
I’m getting a misfire on my 97 RS. It’s stock engine. No work really done to the car yet and recently changed out the spark plugs about 2 months ago. I was accelerating to about 80 on the freeway when my engine light came on. I got the codes checked and came back with P0303. I had the code before but went away by itself. My engine tried to stall itself out below 1000 rpm. Keeping gas on the car keeps it alive, but still runs rough. Swapped spark plugs, check SP wires and they looked good, and swapped to a new distributer and nothing changed. My friend tells me it might be valve seals. Any recommendations?
Team-Integra: Search P0303
 
1 - 2 of 2 Posts
About this Discussion
1 Reply
2 Participants
jjkz24
Team Integra Forums
The Team Integra community is a forum dedicated to Acura Integra enthusiasts to discuss engine building, suspension, repair, detailing and anything else Integra related.
Full Forum Listing
Top