Team Integra Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
last night my 94 ls began dumping coolant from my belt side of the motor. i could hear boiling from over there, then saw coolant coming out. it was dark so i couldnt pinpoint a spot. i got some water and kept refilling it and nursing it home. about 1/2 mile from my house there was a jerk and the motor seemed to sieze up... i tore it open today and found a shredded timing belt was the cause for the siezing, but could this be linked to my water pump causing it to overheat? i bought a new thermostat, head gasket, and timing belt today and if necessary i will be getting a new water pump tomorrow. just wondered if these are related or what else should i check? there are no visible hose cracked and my radiator is in good shape... one more thing, when i was readding water into the radiator, the radiator wasnt even hot... it seems like it would be a water pump or thermostat. any help would be appreciated... this is my only car for work, so the sooner i get this running, the better... thanks
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
well, that sucks... thermostat is good... what is my best bet then? new motor or new head? this was an $1800 car a year ago, so im not wanting to put more than like $500 in it... what are my options now then?
 

·
Registered
Joined
·
314 Posts
well if your valves are bent then its going to prolly run you more then 500 bucks. IF you are lucky then when the t belt broke it might of stopped before anything touched but thats like 1 in a million chance of happening...good luck
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top