Team Integra Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a rhd converted 01 integra with a jdm itr hid front end. The front end is wired with a cjs wiring conversion harness. The car is wire tucked however the only wires that were cut and extended were the horn and radiator fan. So, when I go to turn the headlights on, I only have fogs. No headlights or high beams. The high beam indicator does not light up in the cluster. I removed my jdm switch and installed the usdm switch for testing purposes. Now I have headlights and high beams however they are reversed. I ordered a new jdm combo switch however still don’t have headlights. Next, I took it apart and cleaned it as per the instructions in the article. Still nothing. I’m stumped. Fuses are good. Is it possible I have 2 bad switches on my hands, however unlikely? Is the chassis harness from usdm compatible with a jdm switch? What am I missing. Grounds are good. Anyone have any ideas?
 

·
Registered
Joined
·
6 Posts
Make sure that the switches for the headlamps are universal when dealing with NAFTA (USDM) and JDM parts. Also make sure that the USDM part for LHD and RHD are interchangeable. many issues when dealing with the RHD vs LHD is that most parts have to come from over seas, if the RHD vehicle was upfitted with a USDM "JDM" conversion kit for a LHD instead of a RHD the wiring can be way off.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
The issue has been resolved. The jdm switch works just fine and like I said I have a cjs wiring conversion harness. When I wore tucked it, i repinned the low beam connector backwards by mistake, and had the plugs for high beams and low beams mixed up. The car had been apart for a long time and I just didn’t remember which color plug was for low and high beam. It’s all good and my lights work perfectly.
 
1 - 3 of 3 Posts
Top