Team Integra Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
A few months back I bought a 2000 Integra LS. Shell is in mint condition. But she’s an auto (for now) and has about 195k miles. Since I bought the car. When I’m cruising the car is quiet and fine. But when I lightly accelerate, or punch it to get on the highway. I hear a high pitched rattling/clicking sound coming from the engine area. When getting on the highway it will make this noise at around 4500rpm. And when cruising it will make the noise until they engine reaches a higher rpm. Usually quiets down around 3 when doing so. When I have the car in neutral and rev it up the sound is gone completely. I’m concerned so I want to address it quickly. But I can’t pinpoint the culprit. Wether that be old fuel injectors, or a badly needed valve adjustment. Or even engine flush, I have no idea. I’ve hit a brick wall. So I’m curious if anyone else knows WHAT this is and how I can fix it. Thank you in an advance
 

·
Registered
Joined
·
16 Posts
If you haven't tried premium gas, it might be so carboned up that it's detonating. You also can have a broken valve spring, as in just one coil on the end is broke off. This would allow the spring to still have enough pressure to close usually, but bounce at particular rpm.
I had that happen in an American V8 with single coil valve springs. It ran fine but was noisy and more so at different rpm. Then it broke again and ruined the engine. I have a high level of confidence that this is what happened because the spring was in three pieces.
 
1 - 3 of 3 Posts
Top