Team Integra Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
194 Posts
Discussion Starter · #1 ·
Hey guys..

To make a long story short...it was snowing pretty bad here in Toronto and I was at work at that time at night and my car slipped on the ice while making a turn around the corner and I managed to gain control but not fully...I smashed into a frozen sand that were stacked up like a hill (construction site)...my front bumper at the passenger side came loose along with a broken signal (the amber thing on the bumper) and broken front bulb (1157) for the signal....

after this incident, these are the problems I am facing now:

1) Headlights and brake lights work fine, but the climate control, gauge,, the back lights will also not light up at all (when braking they will lit up), signal lights along with the right and left indicators will not work at all....

2)upon acceleration of more than 80km/h...my steering wheel shakes (vibrates) like a *****..

I hope you guys can help me out and I appreciate it.

Thanks
 

·
Registered
Joined
·
3,386 Posts
well balance and alignment first off to help with the vibrating and they will find if anything was damaged causing the vibration... and check all of your fuses in the cabin and under the hood... they could have been jard loose or blown for some reason.. who knows that lights thing is real akward tho. never heard anything like that before.
 

·
Registered
Joined
·
194 Posts
Discussion Starter · #3 ·
add to the list emergency lights are not functional also
 

·
Registered
Joined
·
2,763 Posts
Most likely it could be a # of things, but whenever you have a lighting problem...always check the fuses under the hood and the steering column. Also make sure that all your electrical wiring is intact. Good luck.
 

·
Registered
Joined
·
1,302 Posts
1) Headlights and brake lights work fine, but the climate control, gauge,, the back lights will also not light up at all (when braking they will lit up), signal lights along with the right and left indicators will not work at all....

Happen to me and way to solve this is take out all the bulb and replace new one where u got hit. If the bulb are broken and air is inside the bulb it will cause the whole car lighting system to react when you break. Hope this will fix your problem cuz it does does for me.
 

·
Registered
Joined
·
303 Posts
I would have a look at the wiring for the light. a wire could have crack in it or a severed wire that is making contact with something else....and a body panel??

I could be way off here but i would inspect the parts and the wiring that was damaged.
 

·
Registered
Joined
·
107 Posts
I had the weird backup light thing as well. I didnt' really do anything, i just took out all of the tail lights (brake lights, tail lights back up lights etc.) and kinda cleaned them up.
 

·
Registered
Joined
·
194 Posts
Discussion Starter · #8 ·
replaced the damaged bulb, but it made no difference...

integcraze on Feb/09/06 said:
1) Headlights and brake lights work fine, but the climate control, gauge,, the back lights will also not light up at all (when braking they will lit up), signal lights along with the right and left indicators will not work at all....

Happen to me and way to solve this is take out all the bulb and replace new one where u got hit. If the bulb are broken and air is inside the bulb it will cause the whole car lighting system to react when you break. Hope this will fix your problem cuz it does does for me.
 

·
Registered
Joined
·
194 Posts
Discussion Starter · #9 ·
got this issue resolved by my mechanic...fuse was gone and tires needed balancing....made a bit of a difference but still shakey past 120km..

but now when I arm my car the parking lights will not flash...nor will it turn on when the car is started
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top