Team Integra Forums banner

1 - 16 of 16 Posts

·
Premium Member
Joined
·
1,322 Posts
Discussion Starter #1
It came in yesterday and I started putting it together today.

The problem - how is this thing supposed to press something straight??? I'm certain there is supposed to be a hole in the mid-frame. In the first pic, the jack sits on that plate which is dangling from the springs. As you extend the jack, the rod attached to that plate should press down on whatever is on the arbor plates below it... but there's no hole through the mid-frame??




How am I supposed to get the press plate to go through straight??
 

·
Premium Member
Joined
·
1,322 Posts
Discussion Starter #4
Those ones are too tall. I wanted one that's more compact. 6 tons should be more than sufficient for what we do on tegs anyways.

Dammit... I did not want to break out the drill but that looks like the easiest option now.
 

·
Premium Member
Joined
·
1,322 Posts
Discussion Starter #6
codenamezero on Jun/05/10 said:
You are just missing a press.

If you meant a bottle jack when you said, "a press", I do have that. It just isn't installed. If you look closer in the second pic, it's in the lower left corner.

Otherwise I have no idea what you mean :p
 

·
Registered
Joined
·
1,420 Posts
When I bought my engine lift from auto zone, the upper support bars were meant to bolt into the top bracket...the holes were not even close. That's when I sanded the coating off, welded them on, and re-sprayed the metal.

Oh well...way better than taking it back and dealing with that
 

·
Premium Member
Joined
·
1,322 Posts
Discussion Starter #11
I called up customer service this morning, and they seemed really cool about it. They're going to send me a second press, which should get here in a couple of days. They said I can either keep the new kit and send the old one back, or rob the frame from the new kit and send the old frame back. The return shipping is paid for with UPS pick-up at my door. Couldn't ask for more!

Here's a link to the press

If this works out, I'll give them props for great customer service!
 

·
Registered
Joined
·
955 Posts
i looked @ the pic and was like "that dont look right". at least they were cool about it and are sending you a new one.
 

·
Registered
Joined
·
9,295 Posts
Summit has great customer service! it sucks that they screwed up the first time, but it does show what kindof a company they are with what they are doing to rectify the situation!
 

·
Premium Member
Joined
·
1,322 Posts
Discussion Starter #15
Wow this worked out as well as it could have!!

The second press showed up in one day. That frame had the hole in it. I pulled the frame and swapped it, then taped the box solid. The UPS guy came back the next day at 6pm to take the kit back.

Couldn't have worked out better! Summit Racing FTW!

 
1 - 16 of 16 Posts
About this Discussion
15 Replies
11 Participants
95integraLS003
Team Integra Forums
The Team Integra community is a forum dedicated to Acura Integra enthusiasts to discuss engine building, suspension, repair, detailing and anything else Integra related.
Full Forum Listing
Top