Team Integra Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
2,097 Posts
Discussion Starter · #1 ·
i deserve a good smack in the head for hooking up my infinity components directly to my head unit...
...but thanks to T-I, i met up with another member last night who promptly told me what a dumb ass i am and that the components needed an amp...


18 watts, 90 watts, eh whats the difference, i hear music...


i sat in his teg and heard what components sound like with an amp pushing them and i almost wet myself!! needless to say, i'm now looking for an amp for the components...
if you're in the same situation, let this be your wake up call... it is clearly a night and day difference when you underpower as compared to when you hook your sh*t up right...

so what are you guys using to push your components?

...and thanks again to TI for all the info/expertise shared by [knowledgeable] members...
 

·
Registered
Joined
·
2,097 Posts
Discussion Starter · #4 ·
thanks for the offers fellas, i'll def consider them... but i'm gonna start a WTB thread as to not ***** this one with buy/sell offers...


and the pic in my sig is what i had in my black LS... it was totaled and the amps haven't been sent to me yet (they're in Houston, TX)...
 

·
Registered
Joined
·
6,638 Posts
I know its possible to run components off a HU though, as this is what i will probably have to do, and i know having an amp makes a night and day difference. but what speakers (components as its in a 95 GSR) would anyone recomend running off a 60x4 alpine HU. thanks for any advice.
 

·
Registered
Joined
·
4,058 Posts
i also have infinity components i custom mounted in my door panels in the stock location for GSR's and such... im running off my head unit also.... guess i never thought about it, let me know what you do sierra.
 

·
Registered
Joined
·
2,097 Posts
Discussion Starter · #10 ·
^ that's the f*cker whose car i was in that had some 'OK' components that were amped...


Nick: i def am looking for an amp right now, but i'm gonna shop around a bit... i always shop around and get good deals on my stereo equip... when i turn the muzak up loud on ma shiat right now, it starts breaking up/distorting and sounds like chit... CJ's sh*t was just loud as f**k and didn't sound gay like his 4x4 teg looks...
 

·
Registered
Joined
·
973 Posts
I'm running a rockford fosgate 501x with boston rally rx67's and an eclipse 8443 ... i'm actually a little dissapointed with the sound.

i can't tell if its because i used to have a sub in the car, or if there's something else that's stopping the speakers from getting necessary power, anybody have any ideas, or is what I am talking about too broad of a subject?
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top