Team Integra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 94 LS and I can't seem to ever get a good launch when I race people. I either peel out for too long or don't give it enough gas. Any advise will be appreciated.
 

·
Registered
Joined
·
836 Posts
Play around with it and always remember what RPMs of a launch give you good results. If a certain RPM made you spin, then go lower, if another didn't give you a good enough launch, go higher, until you figure it out. It's also a good idea to let your tires warm up first (burnouts, he he he...)
 

·
Registered
Joined
·
608 Posts
i normally wouldnt help u but since im in my comp class as skool i guess ill help u out hehe..when u launch and spin the tires for a long time ur very close, do that but next time let off the gass a little bit when u feel it slipping, feather the gas and when u feel the tires hook up to the ground thats when u floor it..ur mashing the gas too soon and too much just give about half the throttle and when u feel it starting to crawl forward then floor it..cant really explain it too well hope i helped u out
 

·
Registered
Joined
·
711 Posts
Heating up street tire will do nothing for you!!
 

·
Registered
Joined
·
6,059 Posts
If found that if I just rev up and spin the wheels I'll get a horrible launch. best thing to do I've found is rev it up, feather the clutch but at least get a chirp out of the tires, and when you get moving floor it and drop the clutch the rest of the way.
 
1 - 8 of 8 Posts
Top