Team Integra Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3,719 Posts
Discussion Starter #1
I was at the car show in boston and I was talking to a car team that was there. And their Integra LS recently put in a Eclipse Turbo. I basically went WTF? How can you do that? I know the LS block is very very good at taking things in.. but a Eclipse Turbo? I don't know much bout the Eclipse's set up. But it just sounded kind of odd..

Anyone wan to enlighten me on their few cents?
 

·
Registered
Joined
·
8,532 Posts
They no doubt put an eclipse turbo with an integra based turbo manifold. I beleave the revhard and dragIII kits both use those turbos.
 

·
Registered
Joined
·
693 Posts
It's not the turbo itself that matters, its the piping and manifold that needs to fit our cars specifically !

[*]DSM= MITSUBISHI Turbos[*]Drag III and Rev-Hard use Garret Turbos[*]Greddy uses MITSUBISHI Turbos[/list]
 

·
Registered
Joined
·
126 Posts
i heard of some guy with a RS puttin in a turbo eclipse engine...everything ecu engine trans....i was like wait wtf
 

·
Registered
Joined
·
890 Posts
That ahs been doen before, but I dont' understand why waist the money. From owning both cars at the same time its hard to get a little respect until you start talkignt he performance and differences between the two. Then to top it off, that's so custom you can't get anything fixed. I wish i had money liek that to waiste.
 

·
Registered
Joined
·
3,211 Posts
doesnt saab use garret as well?
 

·
Registered
Joined
·
3,211 Posts
i was just wonderin. thanks boostC
 

·
Registered
Joined
·
246 Posts
accually the T25 has 2 different manifold set ups....no one buy greddy uses the mitsu. manifolds....most use nissan.....also greddy uses a bigger turbo than the t25 they use a 18g....the t25 will spool super fast but doesn't push as much cfm wise.....as for the 420A kits most use a t3-t4 turbo(star and one HRC kit) hrc uses the super 16G tubro too but the t3/t4 is better...my friend had a star stage 2 on his 95 GS and made 255whp with it but the problem was that the T3/T4 kit on 420A's goes from lag to wheelspin...there is no happy medium...
 
1 - 10 of 10 Posts
Top