Team Integra Forums banner

1681 - 1700 of 2483 Posts

·
Registered
Joined
·
282 Posts
I was just going to ask if you had it inspected until I read it's new.. holy f*ck. I'm sure it'll get sorted without any issues but the waiting must kill you a little bit.
 

·
Registered
Joined
·
166 Posts
Yeah it was awesome,NOT!!! The compressor wheel has shaft play as if he was on the turbo for awhile causing it to thrust out under load and bake contact with the housing causing grooving, I hope it's a quick turn around. Keep your head up buddy it will get fixed.
 

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,684
Yeah I was surprised as well. I wouldnt expect this from a brand new turbo. You would think Precision would have some sort of quality control that would catch an issue like this. Im bummed about not having the car back on the road but even more bummed that the car didnt get tuned. I had to take a day off work, have my friend tow the car down (he works nights so he didnt even get a chance to sleep before having to go back to work), and have SpeedFactory work on tuning it.

There is just so much prep work involved in getting the car to the shop and tuned. I really hope that Precision handles the situation in a timely and proper manner. Ive read a couple horror stories about people who have had issues with brand new turbos and how Precision pointed the finger at installation errors. I guess we will see how it goes!
 

·
Registered
Joined
·
3,648 Posts
I hope they don't try to tell you that you did something wrong.... Unfortunately a lot of businesses aren't afraid to piss off the average joe nowadays. I really hope they do the right thing. If they try to deny coverage make them send you pictures and a formal warranty denial letter with reasoning and rationale for why their are denying coverage. I used to handle for warranty claims for Powertrain parts failures so I know the ins and outs of those situations. I would be happy to look over any info the send you so you have a second set of eyes on it.
 

·
The Enforcer!
Joined
·
5,802 Posts
sorry for what happen to your turbo, hopefully everything will work out. ill shall be diving back into my car this week after the needed break i needed away from my machine.
 

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,687
Feeling like putting in some work on the teg today. During my tune I noticed a small leak and it looks like I am leaking very slightly from the tee where the oil pressure and turbo feed line connect. Its a very small leak so ill probably just have to tighten it a little more or use teflon tape on the connections.

I will also be pulling off my downpipe to wrap that since it runs pretty close to the oil pan. I havent decided how high up on the downpipe I will run it but we will see. When I was researching the heat wrap it looks like DEI makes silicone spray which can be used on top of the heat wrap. Has anyone used this before?


Another thing I would like to do is fill my torque mounts with polyurethane. My drivers side mount is looking pretty weak even though it was replaced a couple years ago with brand new OEM ITR mounts.
Home Made Poly Urethane Engine Mounts | Importnut.net
 

·
Registered
Joined
·
1,201 Posts
Ive got 64a hasports as well. I only window welded my mounts because it was a hair cheaper and I'd have a reason to get under the car. Worst case with this method is you have to pony up and get new mounts anyway.
 

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,693
Alright so it looks like the small oil leak was caused by my oil pressure sending unit being loose. It was fairly loose so I am guessing I might have forgotten to tighten it down but its all good now. Went ahead and checked all of the other fittings as well since I had the line off.

Next up is wrapping the downpipe. I did some research and alot of people say to just use the ultra high temp engine enamel on top of the wrap to help protect it from water. Im just going to end up going that route unless I see the DEI spray at the parts store when I pick up my window weld.

When I pulled off the downpipe I also snapped the bolt on the V-band clamp so it looks like ill be needing another one of those. I think when we loaded onto the trailer it bottomed out on the exhaust causing it to bend the clamp. Oh well you can only expect so much when you purchase a 3 inch vband setup for $15 shipped lol.
 

·
Administrator
Joined
·
43,014 Posts

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,696
Still waiting to hear back from Precision on the turbo. Hopefully ill hear back fairly soon.

Other than that just a small update. I painted the wrap on the downpipe using flat black flame proof engine enamel. Looks pretty good and should hopefully help keep moisture out of the wrap. I put the paint on pretty thick!


Replacement 3in V-Band clamp


Replaced the dome light with an led lamp. Was going to do the hatch light but it will take a little modifying to get it to fit. Got both lamps for $4 shipped.


Before (in my dark garage)


After


I never posted up a completed shot of my gauges. Left to right: oil pressure, wideband, boost, and oil temp. They have 7 colors to choose from but I usually just leave them on the red setting since it matches the amber cluster pretty well.


Received my calendar yesterday. Turned out pretty well.

 

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,698
Just called Precision. They said that my turbo is still in line to get inspected. I should be hearing back from them early next week. I am hoping to get the car tuned before the end of the year if possible just depends on how quick they can send out the new turbo. As for right now not a whole lot going on with the teg just collecting dust.
 
1681 - 1700 of 2483 Posts
Top