Team Integra Forums banner

1381 - 1400 of 2483 Posts

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,382
Finally got the plastidip off so my rims are flat black once again.


Postin up


Random pics I took a while back that were on my card



Saturday is ForumFest which should be pretty fun then my B-day on Sunday. The ForumFest trip may possibly be the last NA drive for the teg. Planning on pulling the motor within the next couple weeks to prep for turbo (install turbo, clutch, oil cooler, LMA's and some other stuff) then sell off my NA parts to fund the build.

Seen this and thought it was pretty funny because my girlfriend has no idea that I am boosting my car haha.
 

·
Registered
Joined
·
2,204 Posts
My birthday is Wednesday lol. And I'm the same way, don't randomly change the oil and opening a package, you'll get that, oooh, what's that baby... Huh? What's what? Oh this, something I had laying around just putting it on now.
 
  • Like
Reactions: drmix

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,384
Bought new tabs for the teg. Shes good until next year. Love how you can pay for them online then just go pick them up. Makes it less awkward when I pick them up since my car is registered under an address a few hours away for emission reasons.

Going to call SpeedFactory tomorrow and see if theres any update on the turbo since I havent heard anything yet and its been about a week and a half.

I have had a weird issue with the clutch recently on the car which is kind of weird but it started about a week or two ago. What happened first was after sitting for a couple weeks I started it up and went to put it in the gear and it grinded almost like the clutch wasnt working. I pumped it like 10 times and tried it again and it worked just fine after that. Then this last weekend after the car had sat for about a week it did the same exact thing. This time it would do it constantly after driving for a few minutes then pulling up to a stop light and trying to take off. Im pretty sure I just need to bleed/flush the clutch system which I will do before driving the car this weekend. I dont see any leaks at the pedal or underneath the CMC so im guessing its just air in the lines or something. Havent bled or flushed the system since pre-dragon run last year and that was after a motor swap plus a cross country trip so I think its due lol.

Other than that havent bought anything new for the teg just holding onto my money until I see how this pay check looks. Planning on crossing the S300 V3 off of the list this weekend then from there its just small parts to go.

Found this video of the V3 app in action. Pretty cool stuff.
 

·
The Enforcer!
Joined
·
5,802 Posts
J
Don't forgot to let me know the status on USPS issue we are going though. I haven't filed anything because I haven't instructed me to.
 

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,389
J
Don't forgot to let me know the status on USPS issue we are going though. I haven't filed anything because I haven't instructed me to.
Just got my paperwork today for filing the claim. Going to fill it out in a couple days and send it in.
 

·
Registered
Joined
·
2,902 Posts
Nice progress on the car.
As far as USPS, my recent experiences haven't been great. I shipped two items priority mail (2 days shipping time), and both took 4 days...unacceptable in my book especially since I paid for priority. In fact, one of the items went from NJ, to CA, back to Minnesota. Why? I don't know.
Then the other item, the postman "misdelivered" it but thankfully corrected it the next day...still unacceptable though.
Then, Z shipped me some tools, no one was home at my address to sign for the package so they left the slip, I signed the slip for them to leave it there, and what do I see the next day waiting for me when I got home? ANOTHER slip RIGHT ON TOP of the slip I signed and had them leave at my address.
 

·
Registered
Joined
·
512 Posts
Just got my paperwork today for filing the claim. Going to fill it out in a couple days and send it in.

I had a fair experience with the USPS. The climate control that was sent to me was damaged. I filed the claim, posted the pictures showing it was damaged, and they reimbursed me. My package wasn't missing though. Good luck bro! Hopefully it will all get worked out.
 

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,392
Called SpeedFactory today to check on the status of my turbo. Looks like there was a mix up when they placed the order with Precision. Apparently when they ordered it there were a couple other turbos on the same order. One of the turbos werent in stock so the order wasnt complete and they were holding the shipment until the other was able to ship out. They called Precision and they will be shipping my turbo tomorrow by itself. Not a big deal since its just going to sit on the shelf for a couple weeks anyways. So it will finally be here next week. They were thinking Friday at the latest.
 

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,394
ForumFest tomorrow!

Clutch master cylinder got replaced today. Refilled and bled the system with super blue as usual. Clutch feels a bit firmer than before which is a good sign. The fluid that came out smelt and looked pretty bad almost like someone drove the car cross country or something lol.
 

·
Premium Member
Joined
·
4,423 Posts
Discussion Starter #1,398
Got a call from SpeedFactory today! The Precision 5531 has arrived!





Forgot to take a pic of it but nothing like seeing a list of world record setters listed on the Precision box and seeing people from the shop your working with.
Competition Clutch Outlaw Honda Civic | SpeedFactory Racing

Also received this from MorningZ, the infamous Quad-Pod! Been looking for one for over a year and was about to just give up and go another route.



Been collecting parts and working on my turbo build for a while now and my girlfriend still doesnt know. I think this might make her figure it out lol.
 
1381 - 1400 of 2483 Posts
Top