Team Integra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3,353 Posts
Discussion Starter #1
I know there have been numerous posts on this topic, and all of them are at the point that people need to replace their radiators...the problem I have is that I have changed my radiator and I still have a problem. I was driving one night and my car went into the red zone, I found out that there was a noticble crack in my radiator. Replaced it with a 2 core aluminum radiator, a new thermostat, and new radiator cap. 3-4 weeks it ran perfect in the right temp and everthing. Then excessive pressure started building up in my coolant system, so much that my upper radiator hose was about to blow, and caused my car to over heat again. I replaced the hose, and still more pressure. Got a new cap. Boom! Fixed the pressure problem, but still over heating and leaking somewhere because there is coolant under my car after driving it. Where are some spots that are known to leak I can check out, or is my engine toast??
Thanks guys!
Nick
 

·
Registered
Joined
·
9,908 Posts
wow, that sucks man, try going back to whoever did the radiator and have them look at it. Seems like they didnt do such a great job installing it
 

·
Registered
Joined
·
3,882 Posts
i'm thinking it's clogged in the block or head somewhere... that could be bad, depending on what's causing the blockage.
 

·
Registered
Joined
·
302 Posts
humm maybe your water pump isent pumping? maybe it is leaking because the new cap is bloowing off the pressure and that is why there arent any pressure issues...maybe a clog...you by chance don't have a turbo do you? if so i have a couple ideas on that...sorry never seen anything like this....first thought when i was reading was your thermo but you said you replaced it...make sure that is installed right...if you have a turbo pm me and i have a couple suggestions
 
1 - 5 of 5 Posts
Top