Team Integra Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
739 Posts
Discussion Starter · #1 ·
Right as I got off the freeway earlier, my check engine light came on and it appears to be Code 22 - VTEC Oil Pressure Switch. VTEC still engages just fine from what I can tell. The other weird thing that started happening at the same time is the temerature guage will go up to just below half if I am stopped, but once I start moving it goes down to about 1/4, then slowly creeps back up to the mark just below half while I am driving. Is there anything I can look into for this? Everything has been working good so far since I got the car out of the garage a few days ago from winter. Current setup:
AEM CAI
DC JDM 4-1 Stainless Header
Hytech Exhaust
Hondata Intake Manifold Gasket
Oil Pressure Guage, but the stock sender is still setup inline so it receives pressure readings as well.
ACT Clutch/Clutchmasters Flywheel
APEXi AFCII (all default settings still until I can go to the dyno)
Other than that, all the internals of the engine are stock. Thanks for any tips!
 

·
Registered
Joined
·
1,980 Posts
umm order the part from acuraautomotiveparts.org

it's like $46 and literally takes a minute to install. Just did mine a week ago after failing emmissions, then my cel was gone.
 

·
Registered
Joined
·
739 Posts
Discussion Starter · #3 ·
I just was not sure if it is the actual part, or if there is some malfunction going on in my engine. Oil pressure looks normal according to my guage, but I just figured I would check!
 

·
Registered
Joined
·
1,980 Posts
yeah, when mine went out vtec went out, but a day later vtec still engaged, but the cel was still on, so i replaced the part, it went away, and i passed emmissions
 

·
Registered
Joined
·
739 Posts
Discussion Starter · #5 ·
For those thate were wondering, the Code 22 was NOT caused by the senser being faulty, but rather by my VAFC being set incorrectly. I searched around a bit more last night before I ordered the part (good thing I didn't order it!) and saw some posts relating a Code 22 to the VTEC engagement point being set incorectly. The disengagement point has to be at least 300rpm lower than the engagement point, but mine was set to engage at 4400 and disengage at 4200. I backed it off to 4100 (stock setting I believe, I will be leaving it there until I can get my VAFC properly tuned) and everything seems OK now!
 

·
Registered
Joined
·
377 Posts
you need to check your oil level before buying parts..
as for temp gage, you may need thermostat or have a coolant leak...
 

·
Registered
Joined
·
685 Posts
I am getting this error, don't have the vafc2 tuned at all, just did the initial setup now it is giving me the code 22.

oil level fine.
I ordered the gaskets #12 and #14 so I can replace and clean the carbon build up out so the sensor will read correctly.
image to reference parts
parts available at acuracarland
 
1 - 9 of 9 Posts
Top