Team Integra Forums banner
1 - 20 of 21 Posts

· Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
My clock when I bought the car said 1:00. Which was actually about 5 mins off when I did get it, so I didn't worry about it. Now I'm not really worried but I hardly ever wear a watch and the only reliable time I have is my cell phone, which I have to get out constantly to check time.

Here's a pic. Hopefully this shouldn't be too hard to fix if possible.

 

· Registered
Joined
·
662 Posts
i know this might be dumb but you said that you checked the buttons but did you hold them down? a friend of mine thought his clock was messed up but he was pressing the buttons instead of holding them. dont think this is the same in your case but who knows...
 

· Registered
Joined
·
52 Posts
Discussion Starter · #10 ·
inte94gra on Feb/28/04 said:
i know this might be dumb but you said that you checked the buttons but did you hold them down? a friend of mine thought his clock was messed up but he was pressing the buttons instead of holding them. dont think this is the same in your case but who knows...
No, not stupid. Yes I held down the Reset button for a good 10 seconds, still nothing. The ":" part of it doens't blink either, does anyone else's?
 

· Registered
Joined
·
52 Posts
Discussion Starter · #16 ·
Ok so I pulled it out, took out the plug... did some minor adjustments to the screen color so it's now just a green, then plugged it back in. Still say's 1:00. I thought maybe the outer reset button wasn't hitting the inner reset button (Outer missing the actual inner button) so I held it down for 30 seconds, and still nothing.

I just remembered that someone said I could check the fuse? Which fuse?
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top