Team Integra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
418 Posts
Discussion Starter #1
Ok, I got this code about 2 months ago, took off my solenoid, cleaned the little filter and what not, reset the ecu and all was fine. Well today, I got this code again and am thinking I need to replace the switch. I was doing a search and found this "test" procedure to try, but was wanting to know if this is a valid test for the switch or if I'm just gonna mess up stuff worse?

This is what was suggested be a TI member to test the switch. Is this valid???

"You can disconnect the harness at the switch and jump the connections and if the switch is the problem, VTEC will work."
 

·
Registered
Joined
·
1,443 Posts
I have the same problem if you know anyone with a honda that has vtec then you can borrow there to see if it is the problem. the cost 60 bucks shipped to your door. I will be getting one as soon as i get a chance to go to the honda-acura dealer. I will PM you if i get it and it works but if you get it before i do PM back letting me know what happen.
 

·
Registered
Joined
·
189 Posts
did you check oil level? what modifications do you have to your car also? I might know the fix.
 

·
Registered
Joined
·
418 Posts
Discussion Starter #4
no mods, only a cai, the rest is all stock, and my oil level is just fine, thanks for the suggestions. anything else to suggest??? or is what was suggested a valid switch test??

Thanks
Matt
 

·
Registered
Joined
·
189 Posts
The suggestion I was going to make only would work if you had VAFC because I know 3 people including myself that had a similiar problem and it was happening because the Blue wire wasnt plugged in. Check to see if the VTEC Solenoid is plugged up again other then that I dont know.
 

·
Registered
Joined
·
418 Posts
Discussion Starter #6
yeah, its plugged up, I'm just mostly wondering if this:

"You can disconnect the harness at the switch and jump the connections and if the switch is the problem, VTEC will work."

is a valid test for the switch. I don't want to drop $55 for a switch and that not be the problem. Anyways, I appreciate your suggestions so far, hopefully someone can help


thanks,
Matt
 

·
Registered
Joined
·
2,377 Posts
I suggested this test. I played around some more and this test is not foolproof. You have to already have some understanding of the system. I am not going to explain any further. The Helms does not fully explain what conditions the ECM needs to see to set a code 22. I explained all my findings in detail and how this switch functions which should tell you how to test it. Search all my posts and you should find it. I don't remember the post title.
 
1 - 7 of 7 Posts
Top