Team Integra Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter #1
My '91 LS is having issues. The a/c control panel won't work most of the time. If I try to change the air flow from the floor to the vent (for instance) it won't change about half the time. And I can't get the defrost to work solo at all. The only time I can get air coming from the defrost vents is when I can actually get it to change over to the Defrost/floor setting.
None of the little indicator lights work either unless I press hard on the button and hold it in.

My question is this: Is it controlled by vaccum, and if it is, is there any chance anyone knows where the hose might be in the engine bay? If it's electronically controlled, where can I get a cheap replacement outside of a junkyard?

I did do a search before making this post and came up dry, but I hope I'm not the only one who has had this problem. The car only has 73k miles, it's not time to give up on the little things yet.

Thanks for the help.
 

·
Registered
Joined
·
24 Posts
My ac buttons will get stuck all the time too. i just keep it on defrost/floor. theres websites for oem parts. ("acura part oem" on google). been thinking 'bout getting rid of it anyway. make room for the turbo. who needs ac anyway? take the control panel out and give it a look.
 

·
Registered
Joined
·
26 Posts
The fix for this is easy, the hard part is pulling the control unit out of the car. Your climate control is all electrically controlled, no vacuum. What happens is the connection breaks on each switch and causes the problems you are having. You take the control unit apart, resolder the connections, and it will be good for another 100K miles.
 
1 - 3 of 3 Posts
Top