96 gsr cluster not working but fuel gauge works - Team Integra Forums - Team Integra
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 04-22-2018, 04:45 PM Thread Starter
Junior Member
 
Join Date: Apr 2018
Posts: 1
Feedback Score: 0 reviews
96 gsr cluster not working but fuel gauge works

I have a 96 gsr the cluster stopped working along with the temp and tail lights I found a blown fuse under the steering column I replaced t and it keeps blowing out. I have searched everywhere for spliced wires and found a couple in the trunk by the light I have fixed them but still blows the fuse please help me I have searched and searched read so many forums but nothing
96gsrheadachecar is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Integra Forums - Team Integra forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome