Went lsvtec loss in power? - Team Integra Forums - Team Integra
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 02-24-2019, 04:55 AM Thread Starter
Junior Member
 
Join Date: Feb 2019
Posts: 1
Feedback Score: 0 reviews
Went lsvtec loss in power?

Hi don't be too harsh on me I'm new to this forum. Before the swap my motor was seemingly running lean or rich, had a rough idle, bad gas milage, and would sometimes hesitate to accelerate but other than that pulled fine for an ls. Alright, so I then went lsvtec on my ls integra with lsvtec kit at my local shop (pfi South) . It was a ported gsr head stock and the block is stock. Also had a Blox intake installed and was street tuned on hondata. The day I got it back it didn't seem like much more horse power at all other than past like 6k rpm but the torque was noticeably way worse and the idle was still was bad and my gas milage and seemed to pull inconsistently. It wouldn't hesitate to accelerate though. Compression is 160 to 170 across the board. Should I get it diagnosed at a shop? Seems over my head. 😔
Attached Thumbnails
Click image for larger version

Name:	IMG_20181118_162656_1551002133107.jpg
Views:	8
Size:	164.4 KB
ID:	80378  
Chandlo is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-25-2019, 05:27 AM
Senior Member
 
Join Date: Jul 2002
Location: Washington D.C. Area (MoCo, MD)
Posts: 3,806
Garage
Feedback Score: 5 reviews
Quote:
Originally Posted by Chandlo View Post
it was a ported gsr head stock and the block is stock. Also had a Blox intake installed and was street tuned on hondata. The day I got it back it didn't seem like much more horse power at all other than past like 6k rpm but the torque was noticeably way worse and the idle was still was bad and my gas milage and seemed to pull inconsistently. It wouldn't hesitate to accelerate though. Compression is 160 to 170 across the board.

That is all been done to the motor? If not list everything like ECU, bolts, head studs, camshaft, cam gears, fuel upgrades, etc. so us can help you. 160 is to low.

About time I can now apply for Historic Tags for my GS/VTEC Automatic and no more SMOG
-------------------
In other news: New edition to the family born on August 21, 2018 @ 3:10am

Last edited by phatintegra; 02-25-2019 at 05:30 AM.
phatintegra is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Integra Forums - Team Integra forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
For sale Northeast Ohio lsvtec, b18b, ls trannys, other random parts Tyler Bower For Sale Section - Parts 1 01-17-2019 02:32 PM
loss of power at low rpm alanhaag32 Performance 2 10-30-2018 03:50 PM
Loss of power. da9steve Generation Two 8 08-20-2018 09:36 PM
Rear Power Window - videos? sciconf Generation Three 4 06-19-2018 11:12 AM
Power limit issue on 2000 GS nicoleen7 Performance 1 04-06-2018 10:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome