Help integra wonít go over 4,000 rpm 94 integra LS 1.8 Non vertex - Team Integra Forums - Team Integra
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 10-01-2018, 09:19 AM Thread Starter
Junior Member
 
Join Date: Oct 2018
Posts: 1
Feedback Score: 0 reviews
Help integra wonít go over 4,000 rpm 94 integra LS 1.8 Non vertex

Hey guys, please help my mechanic and I are stumped

óShort version:
-Car idles like itís stuuer or misfire for first 1-2 min then idles fine
-Wonít go over 4000 RPM
-Feels like stuttering or misfiring when pressing on gas peddle a little, enough to maintain a speed if I donít push it runs fine and if I push it a little more like to accelerate it runs great


óLong version below with details:
This is my first post Iím used to having new cars but my dad gave me his integra and IM IN LOVE WITH IT and people think Iím crazy. Itís a 1994 Integra LS 1.8 non Vtec Manuel trans. Iím asking for help because Iíve been keeping really good care of her BUT...... All the sudden I started it and it idled rough for 1-2 min then was fine next I noticed only when I press the gas enough to maintain any speed it would studder like itís misfireing or something about 3-4 times a second THE BIGGEST THING is it wonít go over 4000 RPM in any gear even Neutral it stop and feels like itís redline sometime like it studdering when driving but redline when in neutral. WORST OFF ALL THERE IS NO CHECK ENGINE LIGHT and since itís a 94 there no hook up for the computer I did do the paper lip but go no codes at all. My mechanic whoís amazing and has fixed everything else many other people have failed at in the past or tried to be lame something else and Charge an Arm A Leg AND MY FIRST BORN. This is what Iíve done since the problem
changed oil,
new spark plugs,
new wires,
checked ignition system,

Iíve put a cleaner in there to make sure it wasnít a dirty injector he also did a good inspection

but no common idicators of why itís doing this issue. Things Iíve done since I had the car I. The last year not the issue because car was running fine

New starter
New cap and roator
New exhaust from headers muffler( no clog)
New radiator
New master cylinder
New slave cylinder
New inner tire rods
New outer tire rods
New break pads front
New brake rotors front
New bumper
New tires

YES IVE POURED ALOT OF MONEY INTO THIS CAR BECAUSE I LOVE IT AND ITS MY FATERS GIFT SO IM sentimental about it please help

Mechanic doesnít think itís things that the computer check engine light would come on for if there was an issue like O2 censer, tps, etc.

Any ideas please help Iíll be eternally great full my integra family
STZ1994integraLS1.8 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-01-2018, 07:09 PM
Senior Member
 
Built_not_bought's Avatar
 
Join Date: Aug 2011
Location: USA
Posts: 682
Feedback Score: 0 reviews
I'm just gonna throw some ideas:


1. Fuel pump going out.
2. Fuel filter is clogged and needs to be replaced
3. Distributor
4. Bad gas
5. Timing is off
6. Low compression
7. Vacuum leak
8. Wiring


Good luck.

My Build
404whp
[email protected]
Best 60' - 1.729
Built_not_bought is offline  
post #3 of 3 (permalink) Old 10-02-2018, 05:50 AM
Senior Member
 
Join Date: Jul 2002
Location: Washington D.C. Area (MoCo, MD)
Posts: 3,818
Garage
Feedback Score: 5 reviews
O2 Sensor will put it in Limp mode this is why it cuts out at 4k rpm. Also you got a CEL for the O2 Sensor. this I would replace first.

About time I can now apply for Historic Tags for my GS/VTEC Automatic and no more SMOG
-------------------
In other news: New edition to the family born on August 21, 2018 @ 3:10am
phatintegra is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Integra Forums - Team Integra forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome