oil light flashing / blinking / dimming - Team Integra Forums - Team Integra

Team-Integra.net is the premier Acura Integra Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 08-15-2010, 02:52 AM   #1 (permalink)
Senior Member
 
Real Name: Travis
Join Date: Oct 2007
Location: Ventura, CA
Model: DB8/DA9
Year: 9492
Feedback Score: 0 reviews
Default

I have a 92 integra.

recently my oil light has been flashing, and sometimes it stays on constantly but dim.

I checked the oil and its fine.
I dont have an oil pressure gauge, but vtec always works so based on this im assuming pressure is fine otherwise the vtec oil pressure switch would keep vtec off right? (I know, I know I need a real gauge.)
I just replaced the sending unit
I read that the ICU goes bad and causes oil light problems, I removed it tonight but dont see any visible signs of problems (I'm still replacing the capacitor just in case but I gott wait till tomorrow )

can anyone tell me WHAT ELSE would cause the oil light to blink?
Thanks.
gonzo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-15-2010, 04:03 AM   #2 (permalink)
Senior Member
 
91_LS's Avatar
 
Real Name: Kyle
Join Date: Mar 2008
Location: Carson, NV
Model: Integra
Year: 1991
Articles: 1
Feedback Score: 0 reviews
Default

oil pump might be going out on you?
91_LS is offline   Reply With Quote Quick reply to this message
Old 08-15-2010, 10:07 AM   #3 (permalink)
Senior Member
 
Dynamite's Avatar
 
Real Name: Chris
Join Date: Jul 2010
Location: StL Metro, MO
Model: Integra RS
Year: 1995
Feedback Score: 1 reviews
Send a message via AIM to Dynamite
Default

Maybe one of the wires coming from the ICU rubbed on something and is semi-shorting?
Dynamite is offline   Reply With Quote Quick reply to this message
Old 08-15-2010, 06:41 PM   #4 (permalink)
Senior Member
 
Real Name: Travis
Join Date: Oct 2007
Location: Ventura, CA
Model: DB8/DA9
Year: 9492
Feedback Score: 0 reviews
Default

It's official, oil pressure is fine.

I went out and bought a real oil pressure sensor. At idle when warm I have 30 PSI, when I rev it I get up to 85 PSI.

Im not sure what the pressure is supposed to be but I know you want at least 10PSI per 1k RPM so based on that oil pressure seems fine to me.
gonzo is offline   Reply With Quote Quick reply to this message
Old 08-15-2010, 08:43 PM   #5 (permalink)
Senior Member
 
Join Date: Nov 2009
Location: , OH
Feedback Score: 4 reviews
Default

Does your car have a jumper harness by chance? Reason I am asking is my buddies 99 Civic swapped with a GSR had the oil light doing the same exact thing your saying and it ended up being his jumper harness had a wire loose.
guy_from_nerk is offline   Reply With Quote Quick reply to this message
Old 08-15-2010, 08:52 PM   #6 (permalink)
Senior Member
 
sgtmillhouse648's Avatar
 
Real Name: Malhon
Join Date: Jul 2007
Location: Trailbrakng in, IA
Model: Trailblazer LT
Year: 2002
Articles: 1
Feedback Score: 14 reviews
Default

have you checked the wires going to/from the sending unit?
__________________

2001 Honda S2000 - SCCA Solo B Stock
- FailinConcepts Racing
"One of the great things in motor racing is concentration. When I want to go faster I don't drive any faster, I just concentrate harder." - Jim Clark

sgtmillhouse648 is offline   Reply With Quote Quick reply to this message
Old 08-16-2010, 01:54 AM   #7 (permalink)
Senior Member
 
Real Name: Travis
Join Date: Oct 2007
Location: Ventura, CA
Model: DB8/DA9
Year: 9492
Feedback Score: 0 reviews
Default

@guy_from_Nerk: I dont have a jumper harness.

@sgtmillhouse648: I haven't really inspected it no cause its in a got that plastic over it, should I open it up and see if the wire is messed up?
gonzo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Team Integra Forums - Team Integra forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 02:25 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.